Auf der sicheren Seite bleiben

Mit unserem Service bleibt ihr System aktuell

Updates & Upgrades

für Ihre TYPO3-Installation

Nichts ist ärgerlicher als ein Angriff, der Ihre Website außer Betrieb setzt.

Für die Sicherheit Ihre Systems sind Updates ein wichtiger Bestandteil. Hierzu gehört neben dem CMS auch die verwendeten Erweiterungen.
Neben sicherheitsrelevanten Bestandteilen gehören zu den regelmäßigen Updates auch weitere Bestandteile, die zum Beispiel die Bearbeitung der Inhalte erleichtern oder die Ladezeiten positiv beeinflussen.

Als Internetagentur mit Schwerpunkt TYPO3 CMS kümmert sich der-BERGMANN gerne um die regelmäßige Sicherung und Aktualisierung Ihres Systems.

Update-Planung

Systemsicherheit und Aktualisierungen

Versionskompatibilität

TYPO3 / PHP / MySQL

TYPO3
Version
Support
bis
PHP
Version
Datenbank
Version
TYPO3 v1204-20268.1 - 8.2MariaDB 10.3+ / MySQL 8.0+ / PostgreSQL 10.0+ / SQLite 3.8.3+
TYPO3 v1110-20247.4 - 8.2MariaDB 10.2.7+ / Microsoft SQL Server / MySQL 5.7.9+ / PostgreSQL / SQLite
TYPO3 v1004-20237.2 - 7.4MariaDB 10.2.7+ / Microsoft SQL Server / MySQL 5.5+ / PostgreSQL / SQLite
TYPO3 v910-20217.2 - 7.4MySQL 5.5 - 5.6, MariaDB 10.2
TYPO3 v803-20207.0 - 7.4MySQL 5.5 - 5.6, MariaDB 10.2
TYPO3 v711-20185.5 - 7.-2MySQL 5.5 - 5.6
TYPO3 v6.2 5.3.7 - 5.6MySQL 5.5 - 5.6
TYPO3 v6.1 5.3 - 5.4MySQL 5.5 - 5.6
TYPO3 v4.7 5.3MySQL 5.5 - 5.6
TYPO3 v4.6 5.3MySQL 5.5 - 5.6
TYPO3 v4.5 5.2 - 5.3MySQL 5.5 - 5.6

 

PHP 8.0

Support endete am 26.11.2023

Auch darüber hinaus wird PHP 8.0 zunächst in unseren Hosting-Paketen verfügbar sein.
Um die Sicherheit Ihrer Website, z.B. TYPO3-Installation, Shopware, etc., zu gewährleisten, empfehlen wir ein zeitnahes Upgrade auf eine Version, die PHP8.0 oder höher unterstützt.

PHP 8.x-Unterstützung

Bitte beachten Sie, dass PHP 8.0 und höher von TYPO3 bis v10 LTS nicht unterstützt wird! Sie sollten Ihre TYPO3-Installation daher zeitnah auf TYPO3 v11 LTS aktualisieren. In vielen Fällen bieten Hoster auch nach dem offiziellen Support-Ende (11/2022) noch eine erweiterte Unterstützung von PHP 7.4 bis PHP 8.0. Sicherheitsupdates werden hier nicht mehr eingespielt.

PHP 8.1

Support bis 25.11.2024

Auch darüber hinaus wird PHP 8.1 in unseren Hosting-Paketen verfügbar sein.

  • 00

    Tage

PHP 8.2-Unterstützung

Die aktuellen TYPO3-Versionen v11 LTS und v12 LTS unterstützen PHP bis Version 8.2. Bitte beachten Sie, dass dies (noch) nicht für alle ggf. verwendeten Extensions/Erweiterungen gilt